bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#30858: 27.0.50; tramp-error: Package `tramp-archive' not supported


From: Noam Postavsky
Subject: bug#30858: 27.0.50; tramp-error: Package `tramp-archive' not supported
Date: Mon, 19 Mar 2018 14:21:39 -0400

On 19 March 2018 at 14:08, Kaushal Modi <address@hidden> wrote:

> Looks like something wrong is happening at 2 places?
>
> 1. Magit is trying to do something with
> "tidy_html5_DEV-Linux-64bit.tar.xz/.git"? When
> "tidy_html5_DEV-Linux-64bit.tar.xz" is not actually a dir?
> 2. And that in turn triggering that tramp error, even when this is a local
> file, and shouldn't have tramp involved?

Magit is trying to figure out whether
"tidy_html5_DEV-Linux-64bit.tar.xz" refers to a git repo (in which
case it would add it as a git submodule, instead of plain 'git add').
It does this by checking whether there's ".git" file beneath it.
This seems to conflict with the new archive handling feature of tramp.
Not sure if there is a way to resolve it. If not, then I guess magit
must explicitly check whether "tidy_html5_DEV-Linux-64bit.tar.xz" is a
directory first.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]