bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#31286: 26.1; edebug prevents closing


From: Andreas Röhler
Subject: bug#31286: 26.1; edebug prevents closing
Date: Fri, 27 Apr 2018 15:46:08 +0200
User-agent: Mozilla/5.0 (X11; Linux i686; rv:52.0) Gecko/20100101 Thunderbird/52.7.0

On 27.04.2018 10:46, Eli Zaretskii wrote:
From: Andreas Röhler <address@hidden>
Date: Fri, 27 Apr 2018 10:24:57 +0200

Hi, this is a very old issue, don't see it at https://debbugs.gnu.org/:

when closing a file where a function was instrumented running edebug,
Emacs refuses to get shut down afterwards. After answering the common
closing questionaire, a buffer appears again and again showing

Debugger entered: nil
    edebug--display-1(nil 0 before)
    edebug--display(nil 0 before)
    edebug-debugger(0 before nil)
    edebug-before(0)
    ...

and thats it.

I can reproduce this only partially.  After killing the buffer that
visits the file whose function was instrumented using edebug-defun, I
indeed see an error and a backtrace when I invoke a command which
calls that function.  But I have no problem shutting down Emacs,
either before or after the backtrace pops up.

So I'm guessing some other customization of yours is involved; please
try in "emacs -Q" to see if your observations are different from mine.

If you can reproduce this starting with "emacs -Q", please show a
recipe.

Thanks.



Hmm, currently can't reproduce it any more - whether from emacs -Q or not. Maybe close it for now. As running into this from time to time, I'll try to be more vigilant WRT cause.

Thanks,

Andreas





reply via email to

[Prev in Thread] Current Thread [Next in Thread]