bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#34179: 27.0.50; message hangs when buffer with process visible


From: Eli Zaretskii
Subject: bug#34179: 27.0.50; message hangs when buffer with process visible
Date: Thu, 24 Jan 2019 16:32:52 +0200

> From: Michael Heerdegen <address@hidden>
> Cc: address@hidden
> Date: Thu, 24 Jan 2019 14:19:08 +0100
> 
> Eli Zaretskii <address@hidden> writes:
> 
> > Any chance of you attaching the debugger to Emacs during these "hangs"
> > and showing a C backtrace and a Lisp backtrace (via xbacktrace)?
> 
> Here are the results of one session.  This "fracy" stuff is my private
> stuff, but AFAIK it's only coincidence that it's in the LISP backtrace,
> it often looks different, but 'message' is always there.
> 
> Looks like I have a problem with gc again?

It's GC, allright, and it is caused by :eval in your mode-line format:

> #13139 0x00005589d716ec29 in safe__call (inhibit_quit=true, nargs=2, 
> func=XIL(0x56d0), ap=0x7fff6c0ee780) at xdisp.c:2644
> #13140 0x00005589d716edde in safe__call1 (inhibit_quit=true, fn=XIL(0x56d0)) 
> at xdisp.c:2680
> #13141 0x00005589d716ee57 in safe__eval (inhibit_quit=true, 
> sexpr=XIL(0x5589da045e63)) at xdisp.c:2694
> #13142 0x00005589d71a97cd in display_mode_element (it=0x7fff6c0eebc0, 
> depth=3, field_width=0, precision=-3, elt=XIL(0x5589daa8d373), props=XIL(0), 
> risky=false) at xdisp.c:23973
> #13143 0x00005589d71a9b6a in display_mode_element (it=0x7fff6c0eebc0, 
> depth=1, field_width=0, precision=0, elt=XIL(0x5589da044863), props=XIL(0), 
> risky=false) at xdisp.c:24059
> #13144 0x00005589d71a895b in display_mode_line (w=0x5589d9199fb0, 
> face_id=MODE_LINE_FACE_ID, format=XIL(0x5589da044f33)) at xdisp.c:23550
> #13145 0x00005589d71a8751 in display_mode_lines (w=0x5589d9199fb0) at 
> xdisp.c:23485
> #13146 0x00005589d7195cbf in redisplay_window (window=XIL(0x5589d9199fb5), 
> just_this_one_p=false) at xdisp.c:17642

What is your value of gc-cons-threshold?  And how much time do these
"hangs" take before Emacs is responsive again?





reply via email to

[Prev in Thread] Current Thread [Next in Thread]