bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#34197: 24.5; VC Subversion interface does not work if subvesion uses


From: Lars Madsen
Subject: bug#34197: 24.5; VC Subversion interface does not work if subvesion uses passtype gpg-agent
Date: Fri, 25 Jan 2019 16:05:08 +0000

(could not get mail to work from emacs, so is using my normnal email)

My problem is explained here

https://emacs.stackexchange.com/q/47396/21457

Basically when subversion uses passtype gpg-agent then emacs cannot
communicate with subversion as long as `--non-interactive` is being
used (in vc-svn-global-switches)

Switching it to `--force-interactive` worked for me.

Note I have no issues when subversion is using passtype simple (aka
plaintext password)

Problem observed in Emacs 24.5 and emacs 25.2.2 (default on Ubuntu 18.04).

/daleif






/Lars Madsen
Institut for Matematik / Department of Mathematics
Aarhus Universitet / Aarhus University
Mere info: http://au.dk/address@hidden / More information: 
http://au.dk/en/address@hidden






reply via email to

[Prev in Thread] Current Thread [Next in Thread]