bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#33684: DocView bombs out upon password protected PDFs


From: Federico Tedin
Subject: bug#33684: DocView bombs out upon password protected PDFs
Date: Sat, 26 Jan 2019 23:14:49 -0300
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.1 (gnu/linux)

積丹尼 Dan Jacobson <address@hidden> writes:

> When trying to view a password protected PDF:
> DocView: process pdf/ps->png changed status to exited abnormally with code 1.
> Maybe it should ask for the password.
> emacs-version "25.2.2"

Would something like this make sense? A short patch that adds
`doc-view-pdf-password-protected-p', and an extra option to pass to
Ghostscript (-sPDFPassword=) when the command is invoked (only when the
PDF file is password protected). I tried it out by creating a
password-protected PDF using LibreOffice Writer, and then opening it
with find-file.

Attachment: pdf-passwd.patch
Description: patch


reply via email to

[Prev in Thread] Current Thread [Next in Thread]