bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#34252: 27.0.50; rmail-get-new-mail fails


From: john
Subject: bug#34252: 27.0.50; rmail-get-new-mail fails
Date: Wed, 30 Jan 2019 20:29:29 +0000 (GMT)
User-agent: Alpine 2.20 (DEB 67 2015-01-07)

Just changing lin 2075 it does not crash but after quite a time it says

Getting mail from /mnt/snout/home/jpff/mbox...
movemail: No locks available for /mnt/snout/home/jpff/mbox
(No new mail has arrived)
0 new messages read
You can run the command ‘rmail-get-new-mail’ with g
0 new messages read

and no mail is read

If I understand the message the problem relates to fie locking somewhee.

I tried earlier o explain this used to work but after a hardware/software uorade on the server it failed.

==John ff

On Wed, 30 Jan 2019, Eli Zaretskii wrote:

Date: Wed, 30 Jan 2019 18:10:29 +0000 (GMT)
From: john <address@hidden>
Cc: address@hidden

This could be due to a kernel/NFS problem but te effect on using rmail for
my user-base is a real problem.  The problems with proto being nil in
rmail-remote-proto-p is clearly wrong and despite your statement it does
happen to me on two diffrent computers/users attempting to read mail in
emacs via rmail.

If you leave only the one change in the place where Glenn said proto
could be nil, and revert the changes in the other two places, does the
problem still happen to you?

Thanks.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]