[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug-gnu-libiconv] libiconv depends on libcharset?

From: Bruno Haible
Subject: Re: [bug-gnu-libiconv] libiconv depends on libcharset?
Date: Wed, 7 Sep 2011 04:10:25 +0200
User-agent: KMail/1.13.6 (Linux/; KDE/4.6.0; x86_64; ; )


Benny Siegert wrote:
> I have problems compiling libiconv-1.14 on MirBSD, using the pkgsrc
> framework. The build stops with the following error during "make
> install":
> ...
> ../lib/.libs/libiconv.so.2.5: undefined reference to `libcharset_relocate'
> collect2: ld returned 1 exit status
> *** Error code 1

It appears that the --enable-relocatable option does not work in this release.
As a workaround, you can remove that option this time.

Thanks for the report.

In memoriam Andre Spitzer <http://en.wikipedia.org/wiki/Andre_Spitzer>
            Efat Ghazi <http://en.wikipedia.org/wiki/Efat_Ghazi>
            David Mark Berger <http://en.wikipedia.org/wiki/David_Mark_Berger>
            Ze'ev Friedman <http://en.wikipedia.org/wiki/Ze'ev_Friedman>
            Yossef Gutfreund <http://en.wikipedia.org/wiki/Yossef_Gutfreund>
            Eliezer Halfin <http://en.wikipedia.org/wiki/Eliezer_Halfin>
            Amitzur Shapira <http://en.wikipedia.org/wiki/Amitzur_Shapira>
            Kehat Shorr <http://en.wikipedia.org/wiki/Kehat_Shorr>
            Mark Slavin <http://en.wikipedia.org/wiki/Mark_Slavin>
            Yakov Springer <http://en.wikipedia.org/wiki/Yakov_Springer>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]