[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug-gnu-libiconv] Problem when executing iconv on ARM

From: Bruno Haible
Subject: Re: [bug-gnu-libiconv] Problem when executing iconv on ARM
Date: Thu, 6 Oct 2011 10:40:32 +0200
User-agent: KMail/1.13.6 (Linux/; KDE/4.6.0; x86_64; ; )


Hamid A. Toussi wrote:
> I have crosscompiled libiconv to arm-linux and run it. When i try to
> convert some input file that includes Farsi characters using
> bin/iconv, the program always exits with error "fa.txt:1:0: cannot
> convert", no matter what parameters I run iconv with (I tried
> different options for -f and -t, even -f char and -t char does not
> work). This is due to EILSEQ conversion error as I understand.
> Note that everything is working right when I compile and run iconv on
> a x86 GNU/Linux computer (same file, same options) but the problem
> occurs when I run iconv on our ARM board.

It is not normal that libiconv gives different results on different
platforms (except for the wchar_t encoding, which is determined by
the libc).

As a first step: can you show an example of a conversion that
succeeds on x86 and fails on ARM? I mean the file fa.txt (as an attachment,
or as a hexdump) and the options passed to 'iconv'.

Second, how did you build libiconv (which configure arguments, $CC,

Third, does the problem go away if you compile with less optimization
options (-O0 instead of -O2, for example)?

In memoriam Bahriye Üçok <http://en.wikipedia.org/wiki/Bahriye_Üçok>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]