[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problems building 3.1.[23] on HP-UX 11.11

From: Stepan Kasal
Subject: Re: Problems building 3.1.[23] on HP-UX 11.11
Date: Tue, 22 Jul 2003 14:17:50 +0200
User-agent: Mutt/


On Tue, Jul 22, 2003 at 01:57:39PM +0200, Dirk Heinrichs wrote:
> I want to build gawk 3.1.3 on HP-UX 11.11 and get the following error:
> awk.h:970: parse error before "mbstate_t"

Perhaps the compiler doesn't like declarations spanning over two
lines.  Could you please try to join the two lines?
I wonder whether this helps.

If you want just a workaround, you can simply edit the line 78 of awk.h:
        #define MBS_SUPPORT
so that it reads:
        #undef MBS_SUPPORT

This might enable you to compile gawk without support for multibyte

Looking forward to hear from you,
        Stepan Kasal

reply via email to

[Prev in Thread] Current Thread [Next in Thread]