[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Can't compile gawk-3.1.3 on HP-UX 11.11

From: Stepan Kasal
Subject: Re: Can't compile gawk-3.1.3 on HP-UX 11.11
Date: Mon, 5 Jan 2004 10:23:42 +0100
User-agent: Mutt/1.4.1i


On Mon, Jan 05, 2004 at 09:47:11AM +0100, Witold Witkowski wrote:
> I can't compile gawk-3.1.3 (gawk-3.1.2 also) on HP-UX 11.11 with
> gcc (GCC) 3.3.2:
> awk.h:969: error: parse error before "mbstate_t"
> How could I overcome this obstacle ?

please try the patch attached to this mail, this way:

unpack gawk-3.1.3.tar.bz2, to get a fresh copy
cd gawk-3.1.3
patch -p1 <../gawk-3.1.3-mbs_ac.patch

It should compile without errors (but also without the support for
multibyte characters).
If you want more info, look at gawk-3.1.3/README_d/README.hpux in the
patched tree.

I would be glad to hear from you whether it worked.

Happy new year,
        Stepan Kasal

Attachment: gawk-3.1.3-mbs_ac.patch
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]