[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bug in M4

From: Sam Lauber
Subject: Bug in M4
Date: Sun, 09 Jan 2005 20:00:44 +0100

I am using M4 1.4.2.
I wrote an example of m4wrap which did the following:

define macros
initalize by m4wrapping to an action to remove a temp file

However, I ran m4 -R on it, and it said

(my initalizing message)
(my cleaning-up message)

I expected

(my initalizing message)

I ran m4 -F on the generated file, and pressed EOF. I got
nothing. I expected

(my cleaning-up message)

This seriously reduces the usefulness of m4wrap, since large
applications have to establish cleanup actions, and large
applications typically are in frozen files.
My input file was attached.

Samuel Lauber

Web-based SMS services available at http://www.operamail.com.
From your mailbox to local or overseas cell phones.

Powered by Outblaze

Attachment: test.m4
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]