[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnubg] autoconf/autoheader/aclocal fails now (LONG)

From: Christian Anthon
Subject: Re: [Bug-gnubg] autoconf/autoheader/aclocal fails now (LONG)
Date: Sat, 24 Sep 2005 19:47:49 +0200
User-agent: Mutt/1.5.6+20040907i

On Sat, Sep 24, 2005 at 03:07:32PM +0200, Jim Segrave wrote:
> On Sat 24 Sep 2005 (12:39 +0100), Jon Kinsey wrote:
> > Jon Kinsey wrote:
> > > 
> > > Ok, who is a config expert?  I could "have a go", but I'd mostly be
> > > guessing...
> > 
> > Ok, I've "had a go"... It may all work ok now (I'll try it on my linux
> > box in a minute).  Anyone else who can try building would help.
> > 
> > Note that I've tidied things up a bit (remove myftgl.h and myftgl.c and
> > limited the use of freetype to the font building).
> With autoconf 2.59, autoheader 2.59 and aclocal 1.9, here's what
> happens
> address@hidden jes/gnubg$ autoconf 
> address@hidden jes/gnubg$ autoheader 
> address@hidden jes/gnubg$ aclocal -I m4
> acinclude.m4:17: warning: underquoted definition of AC_DEFINE_DIR

This warning is probably without consequence.

> configure.in:582: warning: jm_GLIBC21 is m4_require'd but is not m4_defun'd

while this kind is not.

Either you are missing a particular library or it is caused by the gnubg
.m4 files being much older than current libraries. You could try and
find the relevant .m4 file in your own or in an older distribution and
place them in the m4 subdir. Otherwise you have to figure out what the
updated version of the auto-tools files would be.

good luck, Christian.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]