[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-gnubg] Re: upgrading GNU packages to GPLv3

From: Joern Thyssen
Subject: [Bug-gnubg] Re: upgrading GNU packages to GPLv3
Date: Fri, 29 Jun 2007 00:25:58 +0200
User-agent: Thunderbird (Windows/20070604)


Is there someone who can help updating all of the source code as described below.


* This program is free software; you can redistribute it and/or modify
* it under the terms of version 2 of the GNU General Public License as

should be changed to

* This program is free software; you can redistribute it and/or modify
* it under the terms of version 3 or later of the GNU General Public License as

in all .c and .h files. Also, please check the .texi files and other places in the code that might specify GPL v2.

We also need to update the file COPYING but I haven't been able to find the updated version. Maybe it will be available after the official release tomorrow.

Best regards,


Richard Stallman wrote:
Hello GNU Maintainers,

Version 3 of the GNU GPL will be released in a few days, which means it
is time to start thinking about upgrading the license on GNU packages.
We would like every GNU package to upgrade its license for the next
release, and to include the new license in its source repository within
the next few months.

Upgrading is straightforward if your licensing situation is simple.  If
you're currently licensing work under GPL v2 or later, or LGPL v2.1 or
later, with no added exceptions, the job is simple.  Put the new version
of the license in place of the old one, and change all the notices that
talk about the license to refer to "version 3 or later".  Be sure to
check source code headers, documentation, and any license information in
the interactive interfaces of your program.  You should not have to
change any other text in those notices aside from the numbers.

If the license for your software does include exceptions, please write
to Brett Smith <address@hidden> to discuss how to handle them.  Some
exceptions may need to be updated -- not to change their policy, but to
use the vocabulary of the new licenses, or work properly with the
details of their requirements.

We're looking for some GNU maintainers who would like to upgrade their
packages on June 29 as part of the GPL v3 release event.  This will mean
working quickly, but the FSF will help if needed.  It's not necessary to
have any new features or other technical changes -- you can simply
relicense your repository and the last release.  As redistributors pick
it up, they will be adopting our defense against threats such as
tivoization and discriminatory patent promises.

If you would like to volunteer for the release event, please write to
all three of us: Karl Berry <address@hidden>, Brett Smith <address@hidden>
and me.

When you make a release with the new license, please email
address@hidden about the change, and please send an
announcement to address@hidden, even if you normally use another
list for announcing new releases.

If your GNU package is copyrighted by the FSF but you did not receive an
earlier message about the GPLv3 upgrade, please email address@hidden so
we can send that to you.

In general, if you have any questions or concerns about upgrading the
license for your project, please write to address@hidden, which will
reach Brett and the rest of the licensing team.  Helping GNU maintainers
with this change is a top priority for him, and all of us.

Thank you,
Richard Stallman, Chief GNUisance
Karl Berry, Assistant Chief GNUisance
Brett Smith, FSF licensing and GPL enforcement

reply via email to

[Prev in Thread] Current Thread [Next in Thread]