[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnubg] gnubg stopped working

From: wayne . lydecker
Subject: Re: [Bug-gnubg] gnubg stopped working
Date: Wed, 21 Nov 2007 12:36:59 -0800
User-agent: Thunderbird (X11/20070728)

Thanks Christian, that worked.  I never used the sound effects anyway.

-- Wayne.

Christian Anthon wrote:
That -q didn't work is a bug, I'll fix that one. You can disable
sounds in Settings->Options->Sound (Remember to save your settings),
or by editing ~/.gnubg/gnubgautorc  (look for the line "set sound
enable yes").


On Nov 21, 2007 7:07 PM,  <address@hidden> wrote:
gnubg locked up on me.  I killed it and tried again and it hangs
at the splash screen.  I do a ^C in the launching window and the
board shows up but it still won't play a game.

Here's the situation.  I'm running RHEL 5 with Gnome.  I compiled
the latest development version and it was working fine for a few
weeks.  The thing I do that most do not do is use gdmflexiserver
to run a second account (wayne2).  The wayne2 virtual terminal
still runs gnubg fine, but I can't run it in the primary
virtual terminal (user = wayne).

I tried running it with gdg.  When it hung I hit ^C and displayed
the stack:

#0  0x00a59402 in __kernel_vsyscall ()
#1  0x00b3ece3 in __read_nocancel () from /lib/libpthread.so.0
#2  0x036af810 in esd_send_auth () from /usr/lib/libesd.so.0
#3  0x036afc5f in esd_open_sound () from /usr/lib/libesd.so.0
#4  0x036b067a in esd_play_stream () from /usr/lib/libesd.so.0
#5  0x036b07ee in esd_play_stream_fallback () from /usr/lib/libesd.so.0
#6  0x036b201d in esd_play_file () from /usr/lib/libesd.so.0
#7  0x080f50cf in playSoundFile (
     file=0x8e42f70 "/usr/local/share/gnubg/sounds/fanfare.wav") at sound.c:130
#8  0x080f51dc in playSound (gs=SOUND_START) at sound.c:172
#9  0x08099975 in main (argc=Cannot access memory at address 0x4
) at gnubg.c:6320

It appears to be a problem with the Enlightenment Sound Daemon (esd).
When I launch with "gnubg -q", I get the same problem.  Does anyone
out there have a clue as to how to get gnubg to run in my primary
virtual terminal.  I believe rebooting solves it, but only temporarily.


-- Wayne.

Bug-gnubg mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]