[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnubg] OS/X check in

From: Michael Petch
Subject: Re: [Bug-gnubg] OS/X check in
Date: Thu, 10 Apr 2008 04:32:00 -0600
User-agent: Microsoft-Entourage/

Most of this was answered in my other email, except a few comments:

On 4/10/08 3:39 AM, "Christian Anthon" <address@hidden> wrote:

> quicktime: thx. I'm considering using libao/audiofile for sound
> instead of esd. I suppose that libao will use a quicktime backend  by
> default and that would work out of the box as well?

Libao is supported under fink and macports. I will have to investigate but
I'm not sure what back end they use on the apple platform. I agree in
unifying as much as we can the sound systems into one interface (The
exception will likely be Windows - just a guess).

>>  ./autogen.sh
>>  export LDFLAGS="-dylib_file
>>  /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib
>>  :/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dyli
>>  b -framework QuickTime"
>>  ./configure --enable-threads --enable-sse=no
>>  make install

Its a bit messy once sent through email. But its not a duplication (Yes it
looks odd, but that's what the  compiler needs to get around a lazy binding
anomaly on Leopard. There is a SPACE after -dylib_file and no spaces up
until -framework.

Info can be found here (with nicer formatting):

> typo? you have the System.*libGLdylib line twice.
> We can add these lines to configure.in if both macosX and board3d are
> detected?

Yes, in fact this was the addition I was going to make after initial check
in. I wanted to get the changes out to Achim.

My intent is to add the extra parameters to LD_FLAGS with APPLE OS/X builds
with Board3d. The main reason I didn't check it in was that I wanted to test
how those parameters affect Tiger 10.4 builds. I usually like to test things
out that I know might be a problem before a checkin but didn't have the time
yesterday. The linker problem didn't originally exist on 10.4 and became a
problem on 10.5.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]