[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnubg] Edit cube position bug

From: Massimiliano Maini
Subject: Re: [Bug-gnubg] Edit cube position bug
Date: Fri, 11 Apr 2008 10:52:49 +0200

Massimiliano Maini/NCE/AMADEUS wrote on 10/04/2008 15:03:45:

> > I finally found a Vmware WinXP system I had archived. Using Vmware 6
> > running Windows XP – SP2 from scratch with a virgin setup + your
> > newest files – the cube acts properly when changing directions (in
> > 2d and 3d) in edit mode (and out of it).

> I tried on my collegue's PC (identical HW, with WinXP, gnubg never

> installed before) and it doesn't work.
> One thing you could check: under win (any) and with my install archive

>  http://www.gnubg.org/media/windows/gnubg-0.16-devel-20080319-
> NOGLADE-setup.exe

> Can you check with dependency walker (http://www.dependencywalker.com/)

> if the gnubg.exe references any dll outside its own dir ?
> I'm tired, I'll check at home under Vista and if it works there

> I blame it on some obscure hw/opengl/driver issue on my office PC.
> MaX.

This thing is driving me crazy. I downloaded my own install archive from
www.gnubg.org, installed it on my home PC (Vista) and ...

                IT DOESN'T FUCKIN' WORK :(((((((

The bloody cube does not change board side when the playing direction
is switched. It does with a 2d board, but not with a 3d one.
However, when a match/session starts, the cube is positionned correctly
(according to the currently set playing direction).

Back on my XP PC at office, some extra tests:

- often, switching to 2d and back to 3d, the cube moves correctly the 1st
time the direction is changed, but not the subsequent times.
- if I check "Show shadows" in the 3d options, then the cube moves but is
messed up when on one side: only 2 faces (and the shadow) are shown.
Also, when the cube is displayed correctly, full screen shows up fine, but
when the cube is shown wrongly (bad side and/or bad drawing) the full screen
is totally messed up. I've put a bunch of screen captures in the zip

        http://www.gnubg.org/media/Cube issue screenshots.zip

- I also noticed that, even in cases where the full screen shows up fine, it
doesn't really work: as soon as I roll and move, the display is totally
messed up.

- if I check "Quick draw" then the cube moves correctly and full screen
works fine.

The XP PC has an Intel 82865G Graphics Controller: maybe it's a bit old
(drivers are up to date) and it does not support latest opengl stuff.
however at home I have a muchmore recent one (ATI X1300 I think), I
would be surprised if it causes such problems. I'll check again tonight.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]