[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-gnulib] Re: drop unlocked-io dependency in getline module?

From: Simon Josefsson
Subject: [Bug-gnulib] Re: drop unlocked-io dependency in getline module?
Date: Thu, 20 Nov 2003 17:24:31 +0100
User-agent: Gnus/5.1003 (Gnus v5.10.3) Emacs/21.3.50 (gnu/linux)

Bruno Haible <address@hidden> writes:

> Karl Berry wrote:
>> I know I am not looking forward to upgrading Texinfo to using
>> all the gnulib modules, precisely because of all those dependencies.
> What is it what disturbs you with the amount of dependencies? The maintenance
> work? Don't you trust the code? The size of the distribution? The time
> "configure" takes to complete?

For me it is that the dependencies create requirements on my code that
make things more complicated.  Some examples:

error: assumes the application add a symbol 'program_name'.  This is
difficult to do properly if my application is a library with its own

malloc: add a #define malloc rpl_malloc which causes code in my
package that doesn't need gnulib to break during link.

unlocked-io (included implicitly by several modules): claims to be
thread unsafe.

alloca.c: depends on xmalloc, which I don't always want to use
(especially if just copy the file and use AC_FUNC_ALLOCA).

getopt: depends on gettext which adds ~15 additional files even if I
don't use gettext.

These are all low-level modules that are implicitly used by many
packages, so there are many other modules that are unusable for the
same reasons.

Being able to parametrize modules would be nice.

(Incidentally, I just stopped using argp and gnulib in gsasl because
of these and other problems...)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]