[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Add 'Required Tools' to README?

From: Simon Josefsson
Subject: Add 'Required Tools' to README?
Date: Tue, 03 Apr 2007 18:10:45 +0200
User-agent: Gnus/5.110006 (No Gnus v0.6) Emacs/22.0.95 (gnu/linux)

Bruno Haible <address@hidden> writes:

> Eric Blake wrote:
>> gperf --version
>> GNU gperf 2.7.2
> Come on! gperf 3.0.1 was released four years ago, and you are still using its
> seven year old predecessor?

I think some of the problems here could be fixed by noting what tools
are required by gnulib developers.  There is no such section in the
gnulib README or gnulib.texi, or did I miss it?  I re-installed the
gnulib daily build bot yesterday, and I had to install these:

c compiler (gcc)
autoconf: minimum version?  recommended version?
gperf: at least 3.x?

More?  'makeinfo'?

I suggest adding this to the top-level README:

--- README      31 Mar 2007 16:55:46 +0200      1.20
+++ README      03 Apr 2007 18:10:18 +0200      
@@ -254,6 +254,24 @@
 to join the autotools-announce mailing list to be advised of such
+Required Tools
+Developers using gnulib are required to have certain tools available,
+here is a probably incomplete list that may nevertheless help you to
+get all tools installed before using gnulib.
+c compiler
+gperf: version 3.x or later
 Copyright (C) 2001, 2003, 2004, 2005, 2006, 2007 Free Software Foundation, Inc.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]