[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gplv3 files and updates

From: Karl Berry
Subject: Re: gplv3 files and updates
Date: Sat, 7 Jul 2007 19:36:14 -0500

    situation at hand

Here is my nutshell on what we've got now:

1. The files in the gnulib repository have GPL license statements.
2. The gnulib module descriptions state that certain packages are LGPL.
   (Most gnulib functionality is packaged as several files => module.)
3. When a gnulib user runs the gnulib-tool script to import such an
   LGPL'd module, the script replaces the GPL with the LGPL in those files.

    why ... available under *both* licenses,

Most projects want to use the files as GPL, not LGPL, since the projects
are otherwise GPL, and it's just complication to have them as LGPL.
This, plus the fact that GPL is "more free" than the LGPL, is why they
are GPL'd in the repo.
(Quite likely there are other reasons too, I can't recall.)
http://lists.gnu.org/archive/html/bug-gnulib/2004-09/msg00131.html is
the original message from Paul Eggert about it.

I guess my main concern is that "we" (via gnulib-tool) are converting a
GPL'd to an LGPL'd file based on external information.  If we are doing
that, who's to say that someone else won't come along and do such a
conversion based on other such information, pointing to this as
precedent?  Ok, it wouldn't be likely to wash in court or anything, but
it still seems fundamentally wrong to me.  Then there's the matter of
making mistakes in the external information, or it being modified
maliciously.  Things would get tangled.

Your suggestion of having just LGPL in the repo and using gnulib-tool to
convert to GPL would be fine.  My recollection is that we didn't go that
way at the time primarily because not every gnulib user was using
gnulib-tool (in particular coreutils wasn't), but I think now g-t is
universal.  So maybe this is now the way to go.

Here's another alternative: for the LGPL'd modules, keep both an LGPL
and GPL version in the repo.  Have gnulib-tool copy the GPL file by
default, and the LGPL file when asked for.  We could autoupdate the
*GPL* version from the LGPL source so as not to impose an extra burden
on people committing to gnulib (ie, not forcing double releases).  

The reason the issue in general is coming up now is that this same
conversion (what Bruno calls "relabeling"; I can't agree) system was
proposed to be extended to GPLv2/GPLv3 (in some way that is not
presently clear to me, so I'm not sure if it's problematic for me or
not).  That's when I decided to bring up the issue again.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]