[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: findprog: don't exit => exit-free base_name, dir_name, etc

From: Jim Meyering
Subject: Re: findprog: don't exit => exit-free base_name, dir_name, etc
Date: Mon, 01 Sep 2008 20:00:22 +0200

Paul Eggert <address@hidden> wrote:
> Eric Blake <address@hidden> writes:
>> how about we go one step
>> further, and have a deprecation period, where for a year or so, we provide
>> mbase_name (returns NULL on failure) and xbase_name (calls xmalloc on
>> failure) but no base_name.
> There's a better solution that doesn't involve waiting a year, and
> deprecation, and so forth (problems that gnulib is supposed to avoid).
> We just change the name of the unprefixed function.  Its name already
> reflects that; it is called "base_name" because it means something
> different from the standard "basename".
> So I propose that we simply change the name of "base_name" to
> "gbasename" (or whatever other name you like), and do something
> similar with the other functions.

The waiting period was predicated upon Bruno's desire for an additional
change that would eventually associate the existing function names with
different semantics.

Since the patch I posted does not change the semantics of base_name or
dir_name, I propose to push it now, and those who want different names
or changed semantics can build on top of that.  Besides, that patch is
already larger than I would like.

Objections or reservations?  Speak soon.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]