[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: libposix installed files

From: Bruce Korb
Subject: Re: libposix installed files
Date: Thu, 30 Dec 2010 18:01:32 -0800
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20101125 SUSE/3.0.11 Thunderbird/3.0.11

On 12/30/10 17:11, Bruno Haible wrote:
> Bruce Korb wrote:
>> libposix now installs the files listed below.
>> include/libposix/iconv_open-aix.h
>> include/libposix/iconv_open-hpux.h
>> include/libposix/iconv_open-irix.h
>> include/libposix/iconv_open-osf.h
>> include/libposix/iconv_open-solaris.h
>> include/libposix/unused-parameter.h
>> include/libposix/warn-on-use.h
> These should not be installed. The script needs to look at the 'Include:' 
> field
> of the module descriptions, see

The "Include:" field is not queried.  The mechanics are that the
"Makefile.am:" section gets plugged into the Makefile.am file:

> Makefile.am:
> nodist_pkginclude_HEADERS += $(ICONV_H)
> EXTRA_HEADERS += iconv.h

nodist_pkginclude_HEADERS must be augmented correctly.
I do not know how to tweak the bootstrap script so that it knows
that sometimes it pays attention to the augmentation and
sometimes it twiddles it.  I think the iconv-h needs to be fixed.
The "nodist_pkginclude_HEADERS" was added to Makefile.am
specifically for libposix's use, so if something other than $(ICONV_H)
is needed, then that should be the fix.

Thank you!  Regards, Bruce

reply via email to

[Prev in Thread] Current Thread [Next in Thread]