[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] stdlib: support non-GCC __attribute__

From: Bruno Haible
Subject: Re: [PATCH] stdlib: support non-GCC __attribute__
Date: Sun, 13 Feb 2011 23:58:49 +0100
User-agent: KMail/1.9.9

Paul Eggert wrote:
> > Here's a proposed patch.
> That looks good as far as it goes,

OK, here's a revised patch. Avoids the #ifndef now, and includes some tests/*.c

> but while we're at it, 
> shouldn't we use a consistent naming convention?
> It's confusing that one .h file uses _GL_ATTRIBUTE_NORETURN and
> another uses ATTRIBUTE_NORETURN, for the same notion.

Good point. Here's a patch to rename these macros, so that they use the
_GL_ prefix which we agreed a couple of months ago is the least risky.

Objections to these patches? Jim? Paul?

> If nobody objects, I'd like to apply a similar patch
> to the C files as well, if only to forestall people
> cutting-and-pasting wrong code from them in the future.

You're welcome!

In memoriam Alexander Samoylovich 

Attachment: 0001-Don-t-interfere-with-a-program-s-definition-of-__att.patch
Description: Text Data

Attachment: 0002-Consistent-macro-naming-for-macros-that-use-GCC-__at.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]