[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: sharutils-4.11 does not compile on Solaris

From: Bruno Haible
Subject: Re: sharutils-4.11 does not compile on Solaris
Date: Wed, 20 Apr 2011 00:16:02 +0200
User-agent: KMail/1.9.9

Bruce Korb wrote:
> What does that page mean that I should do with this bootstrap code:
>      ${glib} --import ${gnulib_libs} | tee import-log.txt
>      echo "${extra_dist}" >> lib/Makefile.am
>      test -f fdl.texi && mv fdl.texi doc/.
>      autoreconf --force --install -Wall || true
> Should I add a prefix:
>      AUTOPOINT=true \
> to the autoreconf line?  Or, should I do the import after
> autoreconf?

I would say:
0. Install gettext 0.18.1 on the machine on which you build the releases,
   and write AM_GNU_GETTEXT_VERSION([0.18.1]) in your configure.ac.
1. call autopoint
2. call gnulib-tool --import
3. call "AUTOPOINT=true autoreconf ..."

Step 0 is necessary because gnulib does not guarantee interoperability with
older gettext releases (due to overlap of .m4 files).

Step 1 installs the .m4 files from gettext.

Step 2 overwrites them with the most recent but compatible versions.

Step 3 generates all further autogenerated files.

In memoriam Charles Delestraint 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]