[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bug#8675: error: token "@" is not valid in preprocessor expressions

From: Christoph Scholtes
Subject: Re: bug#8675: error: token "@" is not valid in preprocessor expressions
Date: Wed, 18 May 2011 19:47:43 -0600
User-agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20110414 Thunderbird/3.1.10

On 5/18/2011 6:27 PM, Bruno Haible wrote:

So, if the reporter was using GNU make
     and the previous Makefile.in was based on gnulib 2011-04-03 or newer
     and the reporter did a make command in the top-level directory that
         recreated config.status before recursing into lib/ and then into
then the situation cannot have occurred.

I was using Debian Squeeze with GNU make 3.81. I executed `make maintainer-clean' at the root and then `./configure' and `make bootstrap' when it failed.

If the previous Makefile.in was not based on gnulib 2011-04-03 or newer,
we need to do nothing; the problem is already fixed.

I am not sure what version of gnulib my Makefile was based on.

If the reporter did "make" in the top-level directory of emacs and it did
not rebuild config.status, even after configure changed, it needs to be
fixed in emacs.

I am not sure how to determine if this was the case, since running ./autogen.sh, ./configure and make bootstrap fixed the problem.

Let me know if I can help to further troubleshoot this.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]