[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 1/2] stat-macros: Enhance to provide block-related informatio
Re: [PATCH 1/2] stat-macros: Enhance to provide block-related information.
Wed, 08 Jun 2011 12:20:38 +0200
Paul Eggert wrote:
> It'd be good to add something like this, thanks.
I like your idea, too.
Those definitions are duplicated in far too many packages.
> A few comments:
> The time-related stat macros are already broken out into
> stat-time.h. Perhaps these size-related macros should
> be broken out into stat-size.h? That way, we could
> leave stat-macros.h alone. Many programs that need
> CHMOD_MODE_BITS (in the current stat-macros.h) don't need
> the heavy artillery used to configure the size-related macros.
> If we make this change, the module should be renamed to
> "stat-size" of course.
In the spirit of dependency minimization, it does sound like
a good idea to put this in a new module.