[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 4/8] maint: fts.c (__opendir2): Remove unused parameter, ofla

From: Eric Blake
Subject: Re: [PATCH 4/8] maint: fts.c (__opendir2): Remove unused parameter, oflag.
Date: Thu, 18 Aug 2011 12:45:41 -0600
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110621 Fedora/3.1.11-1.fc14 Lightning/1.0b3pre Mnenhy/0.8.3 Thunderbird/3.1.11

On 08/18/2011 07:53 AM, Jim Meyering wrote:
From: Jim Meyering<address@hidden>

  lib/fts.c |    4 ++--
  1 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/lib/fts.c b/lib/fts.c
index 776dda5..b8b7c5a 100644
--- a/lib/fts.c
+++ b/lib/fts.c
@@ -1192,7 +1192,7 @@ set_stat_type (struct stat *st, unsigned int dtype)
    st->st_mode = type;

-# define __opendir2(file, flag) \
+# define __opendir2(file) \

See my earlier comments. As soon as we are no longer matching the BSD definition of __opendir2, then we should no longer be using a name that might cause conflict with the BSD definition. How about naming the macro fts_opendir instead?

Eric Blake   address@hidden    +1-801-349-2682
Libvirt virtualization library http://libvirt.org

reply via email to

[Prev in Thread] Current Thread [Next in Thread]