[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: building gnustep-base with gcc-3.1

From: Nicola Pero
Subject: Re: building gnustep-base with gcc-3.1
Date: Thu, 6 Jun 2002 10:01:27 +0100 (BST)

> > Trying to build gnustep-base-1.3.2 on i386-linux with gcc-3.1 results
> > in unusable executables, i.e. starting gnumail and/or affiche:
> > 
> > /usr/lib/GNUstep/System/Applications/GNUMail.app/ix86/linux-gnu/gnu-gnu-gnu/GNUMail:
> > Uncaught exception NSInternalInconsistencyException, reason: extra object 
> > crossref - 0
> [...]
> > Can somebody reproduce this errors or build applications, which run
> > without errors?
> It seems to be a bug in gcc 3.1.
> I filed a bug report to them.
> It generates wrong code when compiling NSSwapI* in NSByteOrder.h with -O2

I tracked a bug in the ObjC compiler which was causing -fstrict-aliasing
to generate incorrect code for your testcase (and other testcases as
well!), fixed it, and committed the fix to the 3.1 branch of GCC CVS (and
am now committing to the main branch).

I think this should fix at least this problem - 3.1.1, which should be out
on 15th July, should then contain the fix.

Problem is - I tried the fixed compiler, and I still don't get a working
gnustep system ... gdnc dies silently when apps connect to it.  :-(

It takes a lot of time to rebuild everything, and I am running out of
time, so it may be I didn't rebuild everything cleanly enough ... or maybe
there is still something wrong - if you/someone can get accurate
reports/description of what's going wrong (if anything still is after the
fix), I can look further into fixing further problems.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]