bug-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug #3347] No default icon for application bundles


From: nobody
Subject: [Bug #3347] No default icon for application bundles
Date: Wed, 07 May 2003 14:44:04 -0400

=================== BUG #3347: LATEST MODIFICATIONS ==================
http://savannah.gnu.org/bugs/?func=detailbug&bug_id=3347&group_id=99

Changes by: Martin Brecher <address@hidden>
Date: Wed 05/07/2003 at 18:44 (GMT)

------------------ Additional Follow-up Comments ----------------------------
Attached is a small patch that will make NSWorkspace return a default image 
when no icon can be found for an application bundle.
It uses the common_UnknownApplication.tiff icon in the Library/Images folder of 
GNUstep. - I simply reused the GNUstep.tiff file for this purpose.

At <http://www.stupid-design.com/martin/GNUstep/shots/DefaultAppIcon1.jpg> and 
<http://www.stupid-design.com/martin/GNUstep/shots/DefaultAppIcon2.jpg> I made 
two screenshots, one using the GNUstep.tiff file as the icon and one using the 
wmaker-unknown-pov.tif which I suggested in the original post.


------------------ Additional Bug Attachment  ----------------------------
File name: NSWorkspace.m.diff             Size:1 KB
Patch to show a default icon for applications that don\'t specify one themselves
http://savannah.gnu.org/bugs/download.php?group_id=99&amp;bug_id=3347&amp;bug_file_id=434



=================== BUG #3347: FULL BUG SNAPSHOT ===================


Submitted by: mb                      Project: GNUstep                      
Submitted on: Sun 04/27/2003 at 20:57
Category:  Gui/AppKit                 Severity:  5 - Major                  
Bug Group:  Change Request            Resolution:  None                     
Assigned to:  None                    Status:  Open                         

Summary:  No default icon for application bundles

Original Submission:  On OPENSTEP application bundles have a default icon when 
the Info.plist doesn't specify one. 

On GNUstep folders with .app extension but without icon information only show 
the default folder icon. (This could be confusing for novice users.)

The default application icon on OPENSTEP features a screen with a question 
mark. For GNUstep I propose one of the following icons:

http://largo.windowmaker.org/images/icons/tifs/wmaker-unknown-pov.tif
http://largo.windowmaker.org/images/icons/tifs/wmaker-unknown-pov2.tif

Both feature a nice GNUstep logo and a question mark.

Follow-up Comments
*******************

-------------------------------------------------------
Date: Wed 05/07/2003 at 18:44       By: mb
Attached is a small patch that will make NSWorkspace return a default image 
when no icon can be found for an application bundle.
It uses the common_UnknownApplication.tiff icon in the Library/Images folder of 
GNUstep. - I simply reused the GNUstep.tiff file for this purpose.

At <http://www.stupid-design.com/martin/GNUstep/shots/DefaultAppIcon1.jpg> and 
<http://www.stupid-design.com/martin/GNUstep/shots/DefaultAppIcon2.jpg> I made 
two screenshots, one using the GNUstep.tiff file as the icon and one using the 
wmaker-unknown-pov.tif which I suggested in the original post.


-------------------------------------------------------
Date: Wed 04/30/2003 at 09:38       By: mb
oops I meant NSWorkspace.m... lack of sleep.

-------------------------------------------------------
Date: Wed 04/30/2003 at 09:37       By: mb
After taking a quick look at NSFileManger.m, I think that I might be capable of 
doing this myself.  :-)
So I will try it myself and send a patch if I get it to work.


CC list is empty


File Attachments
****************

-------------------------------------------------------
Date: Wed 05/07/2003 at 18:44  Name: NSWorkspace.m.diff  Size: 1KB   By: mb
Patch to show a default icon for applications that don't specify one themselves
http://savannah.gnu.org/bugs/download.php?group_id=99&amp;bug_id=3347&amp;bug_file_id=434


For detailed info, follow this link:
http://savannah.gnu.org/bugs/?func=detailbug&bug_id=3347&group_id=99




reply via email to

[Prev in Thread] Current Thread [Next in Thread]