[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Text drawing bug - gaps after 16th character in scaled view

From: Kazunobu Kuriyama
Subject: Re: Text drawing bug - gaps after 16th character in scaled view
Date: Mon, 30 Jun 2003 23:23:48 +0900
User-agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.0.0) Gecko/20020614

Pete French wrote:

The program 'PanelTest' is just the second demo of Nicola Pero's tutorial.
PanelTest.xwd is the image which I had on the screen.  The system is
ix86/linux-gnu/gnu-gnu-gnu and the backend is xlib.

Whats an 'xwd' file and how do I view it ? I ran 'xv' but it gives me

Sorry for little explanation. To see the file,
   $ gzip -cd TestPanel.xwd.gz | xwud
xwd(1) and xwud(1) are the utilities accompanied with X11R6.

Although it may not exactly the same one as Pete French's, I think the
expample is closely related to what you are discussing.

When I run that I get the expected results - i.e. the whole string
appears fine on the panel. I am using art backend though. Could this be font
dependent at all ? I will have a play with some different text in that
App when I get back from the noon meeting which has just been sprung on
me (whilst typing!)


I tried it with a few fonts of different sizes, and got the same results.
What is strange is that some applications display strings correctly while
the other ones not.  When I changed the string of that program, it sometimes
worked fine.  It seemingly depends on the length of a given string.  But
I could not find any behavioral order.

If you feel this example is not relevent to you, please leave it out for
a while. If this is the case, I think I should write another bug report to prevent
other people from being confused.

Kazunobu Kuriyama

reply via email to

[Prev in Thread] Current Thread [Next in Thread]