bug-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug #4658] Broken gpbs when doing pb operations between GS and X


From: Stefan Urbanek
Subject: Re: [bug #4658] Broken gpbs when doing pb operations between GS and X
Date: Fri, 08 Aug 2003 16:41:15 +0200

On 2003-08-08 13:22:35 +0200 Pete French <address@hidden> wrote:

3. GNUstep apps used to freeze for a while (waiting for X selection) when 
pasting from X apps.

Actually I see this. What seems to be happening is that the gpbs dies and
then gets restarted.


btw. i have tried it with running gpbs and the delay seems to be not because of 
crashed gpbs, gpbs was still running. Here is the output:

2003-08-08 16:37:06.211 gpbs[382] <PasteboardObject: 80658e8> get data for type
'NSStringPboardType' version 3
2003-08-08 16:37:06.212 gpbs[382] Owning program failed to convert data.
2003-08-08 16:37:26.219 gpbs[382] Timed out waiting for X selection

I have tried with different X apps, and all do the same, so this problem is not 
dependent on some particuliar X app. Moreover, all this worked fine some time 
ago.

I am also sseeing an odd effect that the first cut and paaste doesnt work.
I needx to do acust and paste within gnustep efore I can paste from X
into gnustep.


same here, in some cases.

Stefan





reply via email to

[Prev in Thread] Current Thread [Next in Thread]