bug-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bugs #6693] *.gorm files are not copied into Resources directory


From: Nicola Pero
Subject: [bugs #6693] *.gorm files are not copied into Resources directory
Date: Thu, 29 Apr 2004 11:28:41 -0400
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

This mail is an automated notification from the bugs tracker
 of the project: GNUstep.

/**************************************************************************/
[bugs #6693] Latest Modifications:

Changes by: 
                Nicola Pero <address@hidden>
'Date: 
                Thu 04/29/04 at 15:28 (GMT)

            What     | Removed                   | Added
---------------------------------------------------------------------------
         Assigned to | None                      | nico


------------------ Additional Follow-up Comments ----------------------------
I'd like to fix this bug, but I couldn't reproduce it.

It works for me (at least for an application).  The command to copy the 
xxx_RESOURCE_FILES is always executed (which is inefficient, as it wouldn't be 
difficult to have clever rules that only copy them when needed, maybe I'll add 
that later), so I don't see how you might have this problem (to see the command 
being executed, try doing 'make messages=yes').

(NB: the AppNameInfo.plist file is a different issue :-)

Can you give me more information on how to reproduce the bug?

Best would be if you send me a makefile which doesn't work, and details of what 
you do and why it doesn't work.

Thanks.






/**************************************************************************/
[bugs #6693] Full Item Snapshot:

URL: <http://savannah.gnu.org/bugs/?func=detailitem&item_id=6693>
Project: GNUstep
Submitted by: Stefan Urbanek
On: Fri 11/21/03 at 13:41

Category:  Makefiles
Severity:  4
Item Group:  Bug
Resolution:  None
Assigned to:  nico
Status:  Open


Summary:  *.gorm files are not copied into Resources directory

Original Submission:  When I edit a *.gorm file in a project, the file is not 
copied into Resources directory of target bundle when issuing next 'make' 
command. I have to do 'make distclean' and 'make' again to have recent version 
of .gorm file there.

Follow-up Comments
------------------


-------------------------------------------------------
Date: Thu 04/29/04 at 15:28         By: nico
I'd like to fix this bug, but I couldn't reproduce it.

It works for me (at least for an application).  The command to copy the 
xxx_RESOURCE_FILES is always executed (which is inefficient, as it wouldn't be 
difficult to have clever rules that only copy them when needed, maybe I'll add 
that later), so I don't see how you might have this problem (to see the command 
being executed, try doing 'make messages=yes').

(NB: the AppNameInfo.plist file is a different issue :-)

Can you give me more information on how to reproduce the bug?

Best would be if you send me a makefile which doesn't work, and details of what 
you do and why it doesn't work.

Thanks.

-------------------------------------------------------
Date: Wed 12/31/03 at 06:25         By: aperez
This problem occurs with ANY resource which is included via the GNUmakefile. I 
ran into it with the AppNameInfo.plist file, which I edited, did a make, make 
install, and it didn't update in the installed appbundle or in the appbundle 
which is created in the compile directory. This really needs to be fixed. Right 
now, the only workaround is either a 'make distclean' as stefan says, or simply 
a 'make clean'












For detailed info, follow this link:
<http://savannah.gnu.org/bugs/?func=detailitem&item_id=6693>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.gnu.org/







reply via email to

[Prev in Thread] Current Thread [Next in Thread]