bug-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #14430] ./configure fails checking for FFI libraries on gcc4


From: anonymous
Subject: [bug #14430] ./configure fails checking for FFI libraries on gcc4
Date: Tue, 6 Sep 2005 00:00:34 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Firefox/1.0.6

URL:
  <http://savannah.gnu.org/bugs/?func=detailitem&item_id=14430>

                 Summary: ./configure fails checking for FFI libraries on
gcc4
                 Project: GNUstep
            Submitted by: None
            Submitted on: Tue 09/06/05 at 00:00
                Category: Base/Foundation
                Severity: 3 - Normal
              Item Group: Bug
                  Status: None
                 Privacy: Public
             Assigned to: None
             Open/Closed: Open

    _______________________________________________________

Details:

Hi. I've tried to compile gnustep-base on PLD-linux, with gcc4 and got
something like this after invoking ./configure (actually invoking it in
rpmbuild with all the needed flags applied, like -I and -L/-l):

checking "use of fake-main definition"... no
checking ffi.h usability... no
checking ffi.h presence... no
checking for ffi.h... no
checking callback.h usability... yes
checking callback.h presence... yes
checking for callback.h... yes
checking "for forwarding callback in runtime"... no
checking "FFI library usage"... none

You do not have an up-to-date libobjc library installed
GNUstep requires ffcall or libffi and proper libobjc hooks to do
invocations and DO.
(This does not apply on apple-apple-apple systems where DO is
not compatible with other GNUstep systems.)

You most likely do not want to build base without DO support. Many
things, including all applications, won't work at all without DO.
If you really want to build -base without DO support, add --disable-do
to the configure arguments.
For more information, read the GNUstep build guide, ffcall section:
http://documents.made-it.com/GNUstep/buildguide.html#FOREIGN.FUNCTION.INTERFACES
configure: error: Incomplete support for ffi functionality.
błąd: Błędny status wyjścia z /var/tmp/rpm-tmp.6122 (%build)

I've tried building it with all variations of libffi installed, ffcall
installed, --enable/disable{libffi,ffcall} and got still the same otput. In
config log:

configure:13780: checking "for forwarding callback in runtime"
configure:13786: /usr/local/bin/gcc -c -fgnu-runtime -I/usr/include
-I/usr/lib/gcc/athlon-pld-linux/4.0.1/include/objc -O2 -march=athlon-xp
-mfpmath=sse -pipe  -I/usr/lib/GNUstep/System/Library/Headers/gnu-gnu-gnu
-fgnu-runtime -x objective-c conftest.c >&5
In file included from conftest.c:1:
./config/config.forward.m: In function 'main':
./config/config.forward.m:5: error: '__objc_msg_forward' undeclared (first
use in this function)
./config/config.forward.m:5: error: (Each undeclared identifier is reported
only once
./config/config.forward.m:5: error: for each function it appears in.)
configure:13792: $? = 1
configure: failed program was:
| #include "./config/config.forward.m"
configure:13814: result: no
configure:13822: checking "FFI library usage"
configure:13944: result: none
configure:13965: error: Incomplete support for ffi functionality.

Did a lot of experiments wit it (thus the strange include paths etc..), but
it doesn't compile out of a box also.

address@hidden RPMS]$ gcc -v
Reading specs from /usr/lib/gcc/athlon-pld-linux/4.0.1/specs
Target: athlon-pld-linux
Configured with: ../configure --prefix=/usr --libdir=/usr/lib
--libexecdir=/usr/lib --infodir=/usr/share/info --mandir=/usr/share/man
--enable-shared --enable-threads=posix --enable-__cxa_atexit
--enable-languages=c,c++,f95,objc,ada,java --enable-c99 --enable-long-long
--disable-multilib --enable-nls --with-gnu-as --with-gnu-ld
--with-demangler-in-ld --with-system-zlib --with-slibdir=/lib --without-x
--enable-cmath --enable-libgcj --enable-libgcj-multifile
--enable-libgcj-database --enable-gtk-cairo athlon-pld-linux
Thread model: posix
gcc version 4.0.1 20050521 (prerelease) (PLD Linux)







    _______________________________________________________

Reply to this item at:

  <http://savannah.gnu.org/bugs/?func=detailitem&item_id=14430>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.gnu.org/





reply via email to

[Prev in Thread] Current Thread [Next in Thread]