bug-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem Installing Gorm with MINGW32


From: rvermas
Subject: Problem Installing Gorm with MINGW32
Date: Sun, 9 Oct 2005 06:35:59 +0200 (CEST)
User-agent: SquirrelMail/1.4.3a

Hello,

Running GNUstep-base-1.10.1-gui-0.9.4.exe works completely fine.

When installing Gorm-0.11.0 after that, some library related problems arise.

After typing:
 make
the installer starts making libGormObjCHeaderParser, and everything
goes well until linking. Then the linker can't find the objc library, and
generates lots of 'undefined references'.
This problem was solved when I added
        -lobjc
to the GNUMakefile (in GormObjCHeaderParser).

The same thing happens when making GormLib; the same solution worked also.

GormCore also needs '-lobjc', but can't find the GormLib just made, so
I tried several things.

   make install

for the individual components GormObjCHeaderParser and GormLib
does install libGormObjCHeaderParser.a GormObjCHeaderParser.dll,
libGorm.a and Gorm.dll, but the linker doesn't seem to
recognise these.

Then I copied these files to all the places I could think of
and experimented with both '-l' and '-L' options for the linker,
but nothing works. I keep getting tons of messages of the like:

    ./shared_obj/GormPrivate.o(.text+0x37b):GormPrivate.m: undefined reference 
to `_imp__NSLog'

Then I noticed that the files libGormObjCHeaderParser.a and libGorm.a
are only 2 Kb long, while all other *.a libraries all have a decent
length.

Alas, my knowledge of Linux-like systems is only minimal, and the
complexity of the sequence of makefiles is a little too much for
me. As far as I can see something goes wrong with either 'libtool',
'dlltool' and/or 'dllwrap', but since I don't know what these
programs are supposed to do exactly, I hesitate to experiment with them.

This is the output I get with
 make > output
(Lines starting with '**' I inserted here by hand, because those
lines only appear in the shell window):

rm -rf InterfaceBuilder
ln -s GormLib InterfaceBuilder
Making all in GormObjCHeaderParser...
make[1]: Entering directory 
`/e/GNUstep/2005_10/Gorm-0.11.0/GormObjCHeaderParser'
Making all for library libGormObjCHeaderParser...
make[2]: Nothing to be done for `internal-library-all'.
make[1]: Leaving directory `/e/GNUstep/2005_10/Gorm-0.11.0/GormObjCHeaderParser'
Making all in GormLib...
make[1]: Entering directory `/e/GNUstep/2005_10/Gorm-0.11.0/GormLib'
Making all for library libGorm...
make[2]: Nothing to be done for `internal-library-all'.
make[1]: Leaving directory `/e/GNUstep/2005_10/Gorm-0.11.0/GormLib'
Making all in GormCore...
make[1]: Entering directory `/e/GNUstep/2005_10/Gorm-0.11.0/GormCore'
Making all for library GormCore...
 Linking library GormCore ...
** ./shared_obj/GModelDecoder.o(.text+0x4d):GModelDecoder.m: undefined 
reference to `_imp__GSServerForWindow'
******* (Lots of the above) ************
** c:\GNUstep\Development\msys\1.0\mingw\bin\dllwrap.exe: gcc exited with 
status 1
** make[2]: *** [shared_obj/GormCore.dll] Error 1
** make[1]: *** [GormCore.all.library.variables] Error 2
make[1]: Leaving directory `/e/GNUstep/2005_10/Gorm-0.11.0/GormCore'
** make: *** [internal-all] Error 2

The offending lines in make seem to be (extracted with 'make -n'):

************* start extraction ******************
echo Making $operation for $type $instance...; \
make -f GNUmakefile --no-print-directory --no-keep-going \
    internal-${type}-$operation \
    GNUSTEP_TYPE=$type \
    GNUSTEP_INSTANCE=$instance \
    GNUSTEP_OPERATION=$operation \
    INTERNAL_${type}_NAME=$instance \
    TARGET=$instance \
    GNUSTEP_BUILD_DIR="${abs_build_dir}"
Making all for library GormCore...
(echo " Linking library GormCore ...";dllwrap --driver-name gcc \
   \
  --def ./derived_src/libGormCore.def \
  -o shared_obj/GormCore.dll ./shared_obj/GModelDecoder.o 
./shared_obj/GormBoxEditor.o ./shared_obj/GormClassEditor.o
./shared_obj/GormClassInspector.o ./shared_obj/GormClassManager.o 
./shared_obj/GormClassPanelController.o
./shared_obj/GormControlEditor.o ./shared_obj/GormCustomClassInspector.o 
./shared_obj/GormCustomView.o
./shared_obj/GormDocument.o ./shared_obj/GormFilePrefsManager.o 
./shared_obj/GormFilesOwner.o
./shared_obj/GormFontViewController.o ./shared_obj/GormFunctions.o 
./shared_obj/GormGenericEditor.o
./shared_obj/GormImage.o ./shared_obj/GormImageEditor.o 
./shared_obj/GormImageInspector.o
./shared_obj/GormInspectorsManager.o ./shared_obj/GormInternalViewEditor.o 
./shared_obj/GormMatrixEditor.o
./shared_obj/GormNSSplitViewInspector.o ./shared_obj/GormObjectEditor.o 
./shared_obj/GormObjectInspector.o
./shared_obj/GormOpenGLView.o ./shared_obj/GormOutlineView.o 
./shared_obj/GormPalettesManager.o
./shared_obj/GormResource.o ./shared_obj/GormResourceEditor.o 
./shared_obj/GormScrollViewAttributesInspector.o
./shared_obj/GormScrollViewEditor.o ./shared_obj/GormSetNameController.o 
./shared_obj/GormSound.o
./shared_obj/GormSoundEditor.o ./shared_obj/GormSoundInspector.o 
./shared_obj/GormSoundView.o
./shared_obj/GormSplitViewEditor.o ./shared_obj/GormViewEditor.o 
./shared_obj/GormViewKnobs.o
./shared_obj/GormViewResourceManager.o ./shared_obj/GormViewSizeInspector.o 
./shared_obj/GormViewWindow.o
./shared_obj/GormViewWithContentViewEditor.o 
./shared_obj/GormViewWithSubviewsEditor.o
./shared_obj/GormWindowEditor.o ./shared_obj/NSCell+GormAdditions.o 
./shared_obj/NSColorWell+GormExtensions.o
./shared_obj/NSFontManager+GormExtensions.o 
./shared_obj/NSView+GormExtensions.o ./shared_obj/GormPrivate.o \
         \
   -L../GormLib/./shared_obj -L../GormObjCHeaderParser/./shared_obj 
-Lc:/GNUstep/Library/Libraries
-Lc:/GNUstep/Local/Library/Libraries -Lc:/GNUstep/System/Library/Libraries 
-lobjc -lGorm   -lws2_32 -ladvapi32
-lcomctl32 -luser32 -lcomdlg32 -lmpr -lnetapi32 -lm -I.  \
  )
(dlltool --dllname GormCore.dll --def derived_src/libGormCore.def --output-lib 
shared_obj/libGormCore.a)
************* end extraction ******************


The computer I work on runs Windows XP Home edition and has
OpenStep installed, but I don't think this interferes with GNUstep,
since all environment variables for OpenStep start with 'NEXT_'.

I tried running some GNUstep examples to test the base libraries,
and these examples do work properly, so it seems that the
GNUstep system itself is not the origin of the problem.

Could you please tell me what to do to get Gorm (and of course
ProjectCenter) working? I'm working with NextStep/OpenStep for
some 12 years now, and I am addicted to it. I am really glad
that the GNUstep development environment is available now in
such a mature form.

If you don't have enough information about this problem,
I'll be glad to send you additional information.


Rob Vermaseren,
<address@hidden>






reply via email to

[Prev in Thread] Current Thread [Next in Thread]