[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #26535] user created NSImage not displaying properly

From: Fred Kiefer
Subject: [bug #26535] user created NSImage not displaying properly
Date: Wed, 27 May 2009 19:19:46 +0000
User-agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.10 (like Gecko) SUSE

Update of bug #26535 (project gnustep):

                  Status:                    None => Confirmed              
             Assigned to:                    None => FredKiefer             


Follow-up Comment #1:

Hi Scott,

this is just to let you know that I started to investigate these problems.
Sorry for taking so long, but I first was away and then had a lot of other
stuff that needed to be taken care of. On the other hand I really seem to be
the only one to address such issues in GNUstep. We need to change that.

Your bit size is a nice typo, it left me guessing whether you have 32 or 64,
but in reality this isn't that important here.

Thank you for your excellent test application, this clearly shows the
problems. As you pointed out we have two issues, one with scaling and one with
background threads. Up to now I only looked into the first one.

The code at fault is the one in  [NSImage
drawInRect:fromRect:operation:fraction:]. In the scaled case we end up using
the NSBitmapImageRep to draw and not the interally created NSCachedImageRep
(line 1157). And at this point the bitmap is empty, so it doesn't really help.
On the other hand, cached images can only draw scaled via a horrible hack (See
NSCachedImageRep draw]. It would be possible to resolve this for the cairo
backend by moving the actual drawing into the backend, but I still need a
solution for the other backends.


Reply to this item at:


  Nachricht geschickt von/durch Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]