[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #26949] NSTableView missing 'display' after cell selection

From: Tim Schmielau
Subject: [bug #26949] NSTableView missing 'display' after cell selection
Date: Fri, 03 Jul 2009 15:54:22 +0000
User-agent: Opera/9.64 (Macintosh; PPC Mac OS X; U; en) Presto/2.1.1


                 Summary: NSTableView missing 'display' after cell selection
                 Project: GNUstep
            Submitted by: tschmielau
            Submitted on: Fri 03 Jul 2009 03:54:19 PM GMT
                Category: Gui/AppKit
                Severity: 3 - Normal
              Item Group: Bug
                  Status: None
                 Privacy: Public
             Assigned to: None
             Open/Closed: Open
         Discussion Lock: Any



NSTableView misses a 'display' when a new cell is selected, which is highly
confusing for the user who thinks he cannot edit the table data.

The attached patch fixes the problem.

Steps to reproduce:
Open anything that uses a NSTableView, e.g. create a window with a
NSTableView inside and go to interface testing mode.
Double click on any cell.
Double click on another cell. It does not get selected as it should.
Now type something. The cell does get edited, even though the selection was
not highlighted.


File Attachments:

Date: Fri 03 Jul 2009 03:54:19 PM GMT  Name: NSTableView.m.patch  Size: 281B 
 By: tschmielau
patch to fix the problem


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]