[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Build errors

From: Bruno Miguel
Subject: Build errors
Date: Wed, 2 Jul 2008 12:02:21 +0100

I've been, for a few hours, trying to build IceCat 3.0 but I am unable
to do it. I've tried the standard ./configure; make, but I get an
error about missing icons. To try to fix this, I created an image and
renamed an inserted it according to the error. It didn't fix it.

So, I downloaded the binary and saw the build options used
(about:buildconfig) to compile it. I noticed that the
--with-branding=browser/branding/unofficial/ and
--disable-official-branding options where used; so, I copied all the
options in about:buildconfig, commented everything in .mozconfig,
except the extensions option, and ran ./configure with all but the
extensions arguments, and make. It took me more than 30 minutes, only
to fail the build.

make[3]: Entering directory `/usr/src/icecat-3-g1/browser/branding/unofficial'
Makefile:20: ../../../../config/rules.mk: Ficheiro ou directoria
inexistente [it's saying that the file or dir doesn't exist]
make[3]: *** No rule to make target `../../../../config/rules.mk'.  Stop.
make[3]: Leaving directory `/usr/src/icecat-3-g1/browser/branding/unofficial'
make[2]: *** [export_tier_app] Error 2
make[2]: Leaving directory `/usr/src/icecat-3-g1'
make[1]: *** [tier_app] Error 2
make[1]: Leaving directory `/usr/src/icecat-3-g1'
make: *** [default] Error 2

Am I doing something wrong?

Bruno Miguel

reply via email to

[Prev in Thread] Current Thread [Next in Thread]