[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Icecat 4.0 beta 8

From: Mithrandir
Subject: Icecat 4.0 beta 8
Date: Mon, 27 Dec 2010 22:55:45 +0000 (UTC)
User-agent: Loom/3.14 (http://gmane.org/)

I tried Firefox 4.0 b8 recently, liked the speed, and decided to try to compile
a GNU version. :) Thought others might find it useful, so here it is:


(Currently just a 32 bit GNU/Linux build. I used the Mozilla source code merged
with the Icecat svn patches; nothing else.)

The source I used, with the patches already applied, can be found at:
http://www.fileden.com/files/2010/4/1/2813701/mozilla-central.tar.bz2 (62.7M
compressed, 334.2M uncompressed.) For this link, I have limited bandwidth so
please download this only if you really need the source. :D

As this Firefox is beta, it inherits all the bugs plus some. For instance

*The about dialog uses old version, as new version gives a syntax error.

*Get Addons is broken. Manager works okay.

*Get "Error in XML file: [xpconnect wrapped nsIFile] SyntaxError: invalid XML
tag syntax" from terminal. No idea why.

*Privacy extension isn't recognized by default. It's in /extensions, so you
could probably install it anyway.

*Using this version, then switching over to an older version, messes up the
toolbar for the old version. See http://i.imgur.com/ywM7B.png

*omni.jar is not included. I think.

*Probably more things I missed.

It does have some pros though.

*Pages load faster.

*Plugin content is somewhat faster (Gnash specifically.)

*Mostly supports HTML5 and probably OpenGL/WebGL (haven't tested.)


Of course, if you don't feel like messing about with errors, *don't use this
version!* Get the latest stable version of Icecat from any GNU mirror


reply via email to

[Prev in Thread] Current Thread [Next in Thread]