[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug-grep] [bug #13225] -m option doesn't work in win32 version of grep

From: Julian Foad
Subject: [bug-grep] [bug #13225] -m option doesn't work in win32 version of grep
Date: Mon, 30 May 2005 19:05:00 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b) Gecko/20050217

Update of bug #13225 (project grep):

                  Status:                    None => Invalid                
             Open/Closed:                    Open => Closed                 


Follow-up Comment #1:

I guess you are piping standard output from another command into Grep, and
you expect both Grep and the other command to run in parallel and stop as
soon as Grep finds the specified match.  In Windows (at least the older
versions that I am familiar with) pipes are handled by running the first
command, storing its output, and then, after that command is finished,
running the second command, feeding it the stored data.  Thus you have to
wait for the first command to finish before Grep can do its work.  This is
not a bug in Grep, but just a "feature" of Windows.

If you disagree, please re-open this bug report and state exactly what
command you used in such a way that we can reproduce the effect, and state
what version of Windows you are using and what shell (command.com, cmd.exe,
Cygwin Bash, etc.).


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]