[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: savedefault is still not working

From: Torvald Riegel
Subject: Re: savedefault is still not working
Date: Wed, 7 Feb 2001 21:08:58 +0100

On Wed, Feb 07, 2001 at 07:24:42PM +0900, OKUJI Yoshinori wrote:
> > blocklist (hd0,0)/dev/stage2 output:
> > (hd0,0)<3468960,0,512><3468...>...,3469072+72
> It seems that Stage 1.5 passes an invalid sector number to Stage 2. To
> make sure that my guess is correct, can you show the full output from
> the execution of "blocklist"? When running "blocklist", you should
> turn off the debug mode (run "debug" once more).
I had to modify my setup a bit, since I'm preparing the machine to be shipped.
device.map now has the following entries:
(fd0) /dev/fd0
(hd0) /dev/hda
(hd1) /dev/hdb
(hd2) /dev/hdc
(hd3) /dev/hdd
the disk that was hd0/hdb before is now hd3/hdd. I used grub-install /dev/hda
in the hdd system and it worked. The non-debug blocklist-output is now
blocklist (hd3,0)/boot/grub/stage2
my debug hook func still outputs <8176,0, 512> as being read, with
(bootdrive, install_second_sector) being (131, 8176) in savedefault_func.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]