[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

persistent install failures on HP Omnibook 4100

From: Eric Buddington
Subject: persistent install failures on HP Omnibook 4100
Date: Thu, 24 May 2001 18:22:25 -0400
User-agent: Mutt/1.2.5i

I am trying to get GRUB ( to boot my HP Omnibook 4100. The first
partition is about 4Gb, and is the root fs. I have tried various
install options, and always get "Geom Error" or "Read Error", as
described below.

I can boot GRUB from a floppy and use the command line:

grub> geometry (hd0)
drive 0x80: C/H/S = 992/128/63, The number of sectors = 8007552, LBA
   Partition num: 0, Filesystem type is reiserfs, partition type 0x83
   Partition num: 2, Filesystem type is ext2, partition type 0x83

grub> install=(hd0,0)/boot/grub/stage1 (hd0) (hd0,0)/boot/grub/stage2


The geometry and partition layout agrees with fdisk. On reboot, I get
simply "Grub Geom Error". I thought stage1 did LBA now and wasn't
bothered by large partitions. I then try this:

grub> embed (hd0,0)/boot/grub/reiserfs_stage1_5 (hd0)
 18 sectors are embedded.

grub> install (hd0,0)/boot/grub/stage1 (hd0) (hd0)1+18 (hd0,0)/boot/grug/stage2


An odd little chunking sound, and up pops "GRUB Read Error".

The only oddity I can think of is that my BIOS setup reports a
different geometry: 7944/16/63. I don't have an option to choose
normal/large/lba geometries as I do on my desktop machine; I can type
in a CHS geometry manually (max 16 heads/63 sectors), and "LBA Mode
Control" is set to "Enabled" (I tried disabling this and reinstalling,
and it did exactly the same thing and reported the same geometry (with
LBA) as before.

So I'm stumped, and could really use some help figuring this out.  Why
would GRUB get a read/geom error from a (I think) simple install like this?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]