[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Can't configure grub to use less memory

From: Darren Gamble
Subject: Can't configure grub to use less memory
Date: Wed, 23 Jan 2002 15:19:58 -0700

Good day,

I apologize in advance, as I have a feeling that this problem has a trivial
solution.  But, so far it has escaped us.

I'm running Red Hat 7.2 on a PIII with 1GB of RAM.  We've been using the
2.4.7-10 kernel (I believe it was; the one that comes with the 7.2 release)
for awhile no with more problems, but we had upgraded to 2.4.9-13 for its
various improvements.  We hadn't changed the hardware.

Upon rebooting, we found that there were bugs with the DAC960 drivers,
causing frequent kernel panics (about a 50/50 chance of getting to a command
prompt).  A workaround is to reduce the amount of memory the kernel uses,
which is what we're trying to do.

Grub reports version 0.90 on the splash screen.

First, we tried Redhat's suggestion:


... using the statement

append="800M" in the grub configuration file.

This appears to have no affect.  The kernel still boots with access to all
1GB of memory (and the kernel panics continue).  I am not sure if this is a
documentation problem, if grub has changed versions since then, etc...

Reading the grub docs, it suggests to use the "uppermem" option to define
the number of kilobytes of RAM the system uses, which is supposedly passed
as a kernel option.  Again, no affect, even when used in conjunction with
the append option.

Lastly, we also tried to manually add "mem=800M" onto the end of the kernel
boot line.  The GNU grub faq suggests to do this, and kickstart also does
this if it's specified in its configuration.  If that's done, when the
machine boots the root filesystem doesn't get found and the system halts.
Bootup reports:

Cannot open root device "rd/c0d0p1"
Please append a correct "root=" option

... possibly due to some other bug.

The only two solutions that have worked so far (neither of which we like)

1) Physically remove one of the 512 MB memory cards.
2) Use LILO.

Thanks to all who reply,

Darren Gamble
Planner, Regional Services
Shaw Cablesystems GP
630 - 3rd Avenue SW
Calgary, Alberta, Canada
T2P 4L4
(403) 781-4948

reply via email to

[Prev in Thread] Current Thread [Next in Thread]