[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

GRUB Booting Problem

From: Brian Luft
Subject: GRUB Booting Problem
Date: Mon, 18 Feb 2002 21:41:57 -0600

Greetings. I'm having considerable difficulty getting GRUB to boot Gentoo Linux on my computer.

When I boot with GRUB on the MBR, I just get "Error 22". When I boot with GRUB on the partition itself with BeOS's bootman routing me to it, it just locks after it prints "GRUB ".

I've tried recreating my menu.lst several times. I made sure it was named lst as in list, not as in first. I tried making a device.map file to map hdf to (hd0) and changing my menu.lst to boot from (hd0,4). No dice. I tried telling it to boot from (hd5,2) (hdf = 5). Nope again.

Useful information that is probably related:
My hard drive setup:
3 physical drives
/dev/hda - Windows 98 and BeOS
        First partition - BeOS data
        Second partition - Extended for Gentoo
                50MB boot partition (ext3)
                500MB swap partition (swap)
                6.2GBish root partition (ext3).
        Third partition - Windows 2000 (NTFS)
        Fourth partition - FAT32 data
/dev/hdg - Windows 2000 data
Note that hdf and hdg are connected through a Promise Ultra66 card, not directly to the motherboard like hda.

In grub. setup (hd2,<tab> shows my Linux partitions to be:
        (hd2,4) - boot,
        (hd2,5) - swap
        (hd2,6) - root

My /boot contains a symlink to itself called boot, bzImage, and the grub folder. The grub folder contains 8 _stage1_5 files, my menu.lst, splash.xpm.gz, stage1, and stage2.

My menu.lst is the following:
default 0
timeout 30

title=Gentoo Linux
root (hd2,4)
kernel (hd2,4)/boot/bzImage root=/dev/hdf7

Anybody have any ideas?
Thanks in advance! Brian
Brian Luft

reply via email to

[Prev in Thread] Current Thread [Next in Thread]