[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

win2000 loader

From: Onne Gorter
Subject: win2000 loader
Date: Mon, 18 Mar 2002 18:07:45 +0100

Hi there,

I might have found a possible bug in the GRUB bootloader:
I tried to get windows2000 booting with grub so I tried it out with the cool
command interface jou get when you press c. Unfortunately nothing worked. I
really tried everything I could find, and improvised a lot. But suddenly it
struck me that sometimes with unieke sequences of commands, different things
happend when win2000 was loading. So I figure: maybe it is a bug in the
command line interface only, try putting it in the boot menu, maybe an even
different thing will happen: loading windows2000. AND IT WORKED! Good for
me, bad for you, since this implies a bug in the commandline stuff.
        First my setup: (from head, no fancy cut-n-paste)
 /dev/hda1 50MB  ext3 /boot (linux boot)
 /dev/hda2 10GB  ntfs       (windows 2000 partition)
 /dev/hda3 8GB   ext3 /     (linux root)
 /dev/hda4 1.5GB swap       (linux swap)

 I use a redhat 7.2 standard install, so that is your version number (sorry,
to lazy to look it up myself)

Then my final menu command to load windows2000:

 title linux
 title windows 2000
        chainloader (hda0,1)+1

That is it and it works! But it doesnt work if you press c, and then type
the same thing with 'boot' in the end, sometimes you get nothing at all,
sometimes you get only some text in the top section of screen complaining
about ntdll and/or hal, sometimes you get the textmode progressbar in bottom
of screen with errors about /(windowsroot)/WINNT/SYSTEM/CONFIG not found and
others. Recap: all different kinds of errors.
        Of course I tried other commands like:
 root (hda0,1)
 chainloader +1
 rootnoverify (hda0,1)
 chainloader +1
or exoting things with mapping and geometry. Nothing works from commandline
modes. Except when using a floppy disk with grub on it.

My thought on the bug: either you do not leave EB:EA (or whatever place it
must be) with the correct table and the stuff here is random (due to last
function or whatever). Or somehow the chainloader leaves some sort of stack
frame open or something, which can be different from time to time,
disrupting the win2000 boot process due to faulty return adresses. Or
whatever (you probably know more about what could be the case than I do)

whell, that was it (finally), greetz Ozy

reply via email to

[Prev in Thread] Current Thread [Next in Thread]