[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem: GRUB Loading stage1.5Read Error

From: Jos Vos
Subject: Problem: GRUB Loading stage1.5Read Error
Date: Sun, 05 May 2002 17:37:58 +0200


After installing GRUB (0.91) on a system with only a CompactFlash card,
that behaves as /dev/hda *and* works fine with LILO, the boot process
stops with the following message:

  GRUB Loading stage1.5Read Error

What can be the reason(s) for this?  Does it mean it can't load
stage2?  The way I installed grub:

  grub> root (hd0,0)
   Filesystem type is ext2fs, partition type 0x83

  grub> setup --force-lba (hd0)
   Checking if "/boot/grub/stage1" exists... no
   Checking if "/grub/stage1" exists... yes
   Checking if "/grub/stage2" exists... yes
   Checking if "/grub/e2fs_stage1_5" exists... yes
   Running "embed /grub/e2fs_stage1_5 (hd0)"...  22 sectors are embedded.
   Running "install --force-lba /grub/stage1 d (hd0) (hd0)1+22 p 
(hd0,0)/grub/stage2 /grub/grub.conf"... succeeded

I tried with and without --force-lba, with no success.  I also tried
several explicit geometries (using "geometry (hd) c h s" before setup,
is this correct), with no effect.  The BIOS is known to disable LBA
when the CF drive is below 1024 cyls (which is the case).

Exactly the same setup, with a real disk on a "normal PC" with the
same partitioning scheme, works ok.

Furthermore, a standard LILO setup (using the linear option) works
fine too on the CF system!

Any clues?

--    Jos Vos <address@hidden>
--    X/OS Experts in Open Systems BV   |   Phone: +31 20 6938364
--    Amsterdam, The Netherlands        |     Fax: +31 20 6948204

reply via email to

[Prev in Thread] Current Thread [Next in Thread]