[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GRUB fails to boot Win98

From: Graham Smith
Subject: Re: GRUB fails to boot Win98
Date: Sat, 25 May 2002 09:46:03 +0100
User-agent: KMail/1.4.1


I tried the fix and I'm afraid it did not solve the problem, it does make a 
difference however - let me explain.

On my first attempt to test the fix I saw no difference at all, the debug 
statement gave the same output, i.e.:

reading the offset 0x80 in the drive 0x1a0b9a4

and Error 18 was produced again.

At first I was concerned that I had made some mistake in building or 
installing the updated software (including the real_root_func in 
stage2/builtins.c) so to make sure I had done it correctly I swapped the 
parameters to the grub_printf statement you added to chainloader case of the 
switch statement in boot_func in builtins.c and built and installed again.  
Rebooting had the same effect but the debug statement now read:

reading the offset 0x1a0b9a4 in the drive 0x80

proving that I was indeed using the new builtins.c.

Generally, though I have a menu.lst file installed, I have been jumping 
straight into command mode (by pressing c) and entering the commands 
manually, but on this occasion I had actually selected the Windows 98 option 
from my menu, so when it failed it prompted me to press any key to continue.  
By chance I accidentally pressed return twice which had the effect of 
returning me to the menu and selecting Windows 98 again.  Windows booted up 

Investigation has show that this is also true for the unpatched 0.93 build, 
the 0.92 and the clean 0.91 build, but not the Redhat patched 0.91 build 
where I had previously tried selecting Linux or Windows from the menu after a 
failed attempt to boot Windows and the machine had locked up.

I then tried entering the sequence of commands twice manually and after some 
investigations into the variations available I found that the following is 
the minimum sequence of commands that will boot Windows successfully (from 
command line or menu) with the patched 0.93 build:

rootnoverify (hd0,0)
chainloader +1
rootnoverify (hd0,0)

but the following fails:

rootnoverify (hd0,0)
rootnoverify (hd0,0)
chainloader +1

I also discovered that with the unpatched 0.93 build this does not work, and 
in fact I could not find a sequence of commands that did - but entering the 
commands manually and then switching back to the menu and selecting the 
Windows option did work!  This was also the case for 0.91 and 0.92 and even 
the Redhat patched 0.91!

Hope this information helps you track the problem down.


On Friday 24 May 2002 2:57 pm, Yoshinori K. Okuji wrote:
> At Thu, 23 May 2002 20:37:22 +0900,
> Yoshinori K. Okuji <address@hidden> wrote:
> > Thanks for your investigation. That information is enough to debug
> > GRUB. I didn't have time unfortunately, but I'll do that ASAP. Wait
> > for a while, please.
> I've checked in a fix into the CVS. Could you try it?
> Thanks,
> Okuji

reply via email to

[Prev in Thread] Current Thread [Next in Thread]