[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: microSD problem GRUB loading Stage1.5 Read error

From: J.Bakshi
Subject: Re: microSD problem GRUB loading Stage1.5 Read error
Date: Tue, 30 Oct 2007 09:59:47 +0530
User-agent: Thunderbird (X11/20060911)

adrian15 wrote:
> J.Bakshi wrote:
>> Dear All,
>> I have tried to install GRUB 0.97 in the microSD card of motorola L7i
>> mobile.
>> GRUB has detected the microSD of motorola L7i as (hd1) and the fat16
>> partition of that card as (hd1,0)
>> I have executed GRUB shell and then executed root (hd1,0) and setup
>> (hd1)
>> to install GRUB.  Installation was successful as the output says.
>> Now whenever I boot my PC from the mobile ( set as USB storage device),
>> an error comes as
>> "GRUB loading Stage1.5 Read error"
>> I have also tried the "grub-install --force-lba" but this time I can see
>> the word "GRUB" in my monitor and the machine restarted.
>> I have reformated that memory card as ext2 but the same failure :-(
>> How can fix this problem so that GRUB can be booted from the microSD
>> card of my mobile ?
>> thanks in advanced.
> Does it work under qemu?
> If your microSD is /dev/sdc
> Try qemu -boot c -hda /dev/sdc
> and tell us if it boots or not.

Hi Adrian,

yesterday I tested as you suggest. In my linux system the microsd has
been detected as /dev/sda

So I did " qemu -boot c -hda /dev/sda " and it replied back
"could not open hard disk image /dev/sda"

The qemu I am using is version 0.9.0
Please help me to fix the problem so that I can boot GRUB from microsd.

> adrian15
> _______________________________________________
> Bug-grub mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/bug-grub

Joydeep Bakshi, Linux System Admin
Kolkatainfoservices Pvt Ltd,
23A Royd Street, Kolkata 700016, India
Work Phone 91 033 40014784

reply via email to

[Prev in Thread] Current Thread [Next in Thread]