[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Error 2 - grub legacy (0.97) with newer ext3 (debian/ubuntu)

From: Treutwein Bernhard
Subject: Error 2 - grub legacy (0.97) with newer ext3 (debian/ubuntu)
Date: Thu, 6 Nov 2008 08:52:22 +0100

I recently got an "error 2" after installing grub, when
I tried to boot that system. Following up the problem
made clear that grub legacy was not able to read the 
newer/larger ext3 filesystem, although it recognized it.

Googling found http://forums.pcworld.co.nz/showthread.php?p=723490
which I cite here:


Anyway, the new Ubuntu Intrepid release defaults to 
using a 256 byte inode size for its ext3 file system 
rather than the older 128 bytes used in Hardy and in 
prior releases. Unfortunately the Grub version in Hardy 
and before can't handle the larger inode size, so you 
will typically get a Grub error 2 if you try to boot 
one of the newer ext3 partitions.


My work around was to create a (small) boot partition 
formatted as ext2, which worked. 

A quick glance at the source of fsys_ext2fs.c at
convinced me that I neither know enough C nor do I understand 
the ex2/3/4 filesystem  adequately for fixing it ...

  Bernhard Treutwein

reply via email to

[Prev in Thread] Current Thread [Next in Thread]