[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

grub wont find files on new partition with linux install

From: gmcgmc
Subject: grub wont find files on new partition with linux install
Date: Fri, 12 Jun 2009 17:15:40 -0700 (PDT)

I am using grub v-0.97 to boot multiple os's. computer is set up: hda1-winxp,
hda2-vfat which has grub folder, hda3-ubuntu, hda5-swap, hda6-some linux
distro, hda7-some linux distro, hda8-vfat data, hda9-vfat data, hda10-ext2
/home. I set the partition flag on hda2 active so the bios will read that
partition to boot. I install grub to hda2. recently formated (to make
available) hda6 and hda7. Then installed Slackware to hda6. I modified
menu.lst to ad Slackware but it wont boot (wont find kernel or files on
hda6). When I turn on computer I get my menu.lst, go to grub prompt and type
find /sbin/init and the only results are for hd3 (hd0,2). If I boot to
ubuntu, run grub> find /sbin/init the results are for hda3 (ubuntu, hda6
(slackware), and hda7 (os before I formated hda7). The grub folder that is
on hda2 is copied from ubuntu after which I run grub> root (hd0,1) then
grub> setup (hd0,1). It completes successfully. I have done the "install" to
hda2 with setup from ubuntu and the grub prompt at the boot screen. Since
grub from ubuntu can "see" hda6 and hda7 I dont think problem is fault of
BIOS. What do I do to fix this?
View this message in context: 
Sent from the Grub - Bugs mailing list archive at Nabble.com.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]