[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

"error: out of disk" grub rescue on first cold boot

From: Jonathan M. Polom
Subject: "error: out of disk" grub rescue on first cold boot
Date: Sun, 1 May 2011 20:42:44 -0400

Hopefully I can pick up some insight on this problem on this list
since I think it's related to grub nuance. I'm running Ubuntu 11.04 on
a Intel-based system (C2DUO, 4gb ddr2, g33 chipset) with a 1 TB
WD1001FALS SATA drive on channel 0. The BIOS hasn't been updated
recently but I don't believe my motherboard manufacturer has updated
it for a couple years. Anyway onto the problem:

Upon first cold boot, grub does not load the menu or operating system.
Grub2 displays an "error: out of disk" and then goes to a grub rescue
prompt. No length of idle time permits it to load the menu (IE: just
leaving it alone does nothing to help the problem). The really weird
thing is that if I run 'ls' at the rescue prompt and then execute CTRL
ALT DEL to do a warm reboot, grub WILL load Ubuntu next time around. I
do not have any other OS on the machine so grub is configured to just
boot Ubuntu directly (no menu).

I can replicate this problem very reliably. I can also replicate it
using both SATA AHCI and "normal" mode for my SATA controller (intel

I appreciate any help on this issue and am more than happy to provide
config files, logs, etc. to help figure out why this problem occurs.
While this problem doesn't prevent use of my PC, it does require a
very inconvenient workaround.

Jon Polom

reply via email to

[Prev in Thread] Current Thread [Next in Thread]