[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-gsl] [bug #26502] abort in gsl_ran_discrete_preproc

From: Brian Gough
Subject: [Bug-gsl] [bug #26502] abort in gsl_ran_discrete_preproc
Date: Fri, 08 May 2009 10:55:53 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv: Gecko/2009020410 Fedora/3.0.6-1.fc9 Firefox/3.0.6


                 Summary: abort in gsl_ran_discrete_preproc
                 Project: GNU Scientific Library
            Submitted by: bjg
            Submitted on: Fri 08 May 2009 11:55:52 AM BST
                Category: Runtime error
                Severity: 3 - Normal
        Operating System: 
                  Status: Confirmed
             Assigned to: None
             Open/Closed: Open
                 Release: 1.12
         Discussion Lock: Any




I ran over a bug in gsl_ran_dicrete_preproc that manifests only on
certain computers. I've attached info and test case backtrack of two
computers where bug manifests. One of them is Versalogics Cobra
(http://www.versalogic.com/products/ds.asp?productid=164#Specs) -
Pioneer 3-DX onboard computer, and other is Toshiba Satelite Pro U300;
you can see that from the dmidecode.txt. Versalogic's Cobra runs
Debian lenny (gsl version 1.11+dfsg-1) and Toshiba Ubuntu 8.10 (gsl
version 1.11-2).

The problem is with bigs and smalls stack (randist/discrete.c).
Although the same code is used when calculating the size of stacks and
when inserting (that's when the problem manifests) in them it seems it
works differently (FPU unit?). I've solved this temporarily with
allocating stacks of fixed size (Kevents).

Srećko Jurić-Kavelj


File Attachments:

Date: Fri 08 May 2009 11:55:52 AM BST  Name: randist_preproc-bug.tar.gz 
Size: 9kB   By: bjg



Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]